Author Topic: mfi issue  (Read 1317 times)

Offline wideopen231

  • Hero Member
  • *****
  • Posts: 1910
    • View Profile
  • Your Best Time: 1/8 3.70@ 198 1/4 5.78@245
  • Your Engine: Hemi 526 ci alcohol
  • Your Track: Piedmont
  • Your Vehicle: 225 CMC FED
  • General Location: NORTH CAROLINA
mfi issue
« on: August 08, 2022, 08:12:01 PM »
 Been having xxxx of time with this MFI on FED. Normally I know nwhat I am doing with MFI, use to be pretty good at it.This sytem has me pulling out the hair mother nature has not taken yet.

 Simple or should be a system. First had primer system feeding fuel at idle by pulling fuel thru pump and poppet. Fixed with a solenoid that opens only when the pump is on. The bad part I had it idling and super crisp. But extra fuel meant BV setting junk. Now having an issue with bv, but that is just tuning.

Two possible problems.Once the main fuel line seems very soft at cpl points and can see if being sucked shut. Which might explain that even when bv is close it stumbles at higher rpm when esasing into throttle. Second one I am questioning is filter placement. One of FIE's with 10 inlet and outlet. Thinking might be an issue when rpm has pump pulling or trying to pull more fuel. I know with lot of pumps restriction on suction will kill performance of pump alot more than a restriction on the discharge side. Thoughts on both or either causing rough stumbling when bringing rpm up.
Relecting obama is like shooting right foot because it did not hurt enough when you shot left foot

Offline BK

  • Sr. Member
  • ****
  • Posts: 311
    • View Profile
  • Your Best Time: 8.45 / 5.30
  • Your Track: Empire Dagway
  • Your Vehicle: Late 70's FED
Re: mfi issue
« Reply #1 on: August 14, 2022, 04:58:44 AM »
 Unless the line is breaking down and clogging the filter I doubt it would be the issue stumbling from idle. I could see down track. Unless you have a giant pump and are recirculating a ton of fuel.
I have a -10 filter on the inlet without problems. Around 650 hp. I did have issues once when the screen in the filter was too fine. 40 Micron is too fine I think I have a 100 Micron now.
When I hear rough I think too rich could the gas have been leaning it out to the right mixture.
When I hear stumble I think bog which sounds like idle pressure or BV setting.
I had the same journey to get to a solenoid on my primer.
« Last Edit: August 14, 2022, 05:02:43 AM by BK »

Offline wideopen231

  • Hero Member
  • *****
  • Posts: 1910
    • View Profile
  • Your Best Time: 1/8 3.70@ 198 1/4 5.78@245
  • Your Engine: Hemi 526 ci alcohol
  • Your Track: Piedmont
  • Your Vehicle: 225 CMC FED
  • General Location: NORTH CAROLINA
Re: mfi issue
« Reply #2 on: August 14, 2022, 06:32:20 PM »
 Have not been able mto test past week.Starter been in need of replacement, now doing so.  I know there is no gas anything. I ha it woking grat and har go replace some leaking O-rings In bv and decide to replace all. Nozzles have been checked Maybe get new starter in nexr week

. Man this thing has to be haunted. every time I try to get ready to og or get to track something stupid happens with it. I mean fuel injection really? I only have 35 years experience with it should be snap.
Relecting obama is like shooting right foot because it did not hurt enough when you shot left foot